Server ERROR

Post Reply
JJBL
Posts: 76
Joined: Wed Sep 23, 2020 11:59 am

Wed Dec 02, 2020 11:02 am

I am trying to publish a couple of street view business tour but isn´t possiblle. On the other hand, the same tours I could publish them from Gothru without any problem.

Regards,
Javier
Attachments
Captura de pantalla 2020-12-02 a las 10.57.42.png
Captura de pantalla 2020-12-02 a las 10.57.42.png (28.54 KiB) Viewed 2051 times
JJBL
Posts: 76
Joined: Wed Sep 23, 2020 11:59 am

Fri Dec 04, 2020 9:43 am

Hi.

Does it only happen to me?

Regards
Javier
User avatar
Hopki
Gnome
Posts: 11458
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sat Dec 05, 2020 9:38 pm

Hi Javier,
Odd, is the image already in your Street View account?
What happened in the past when Google was removing images, the Pano2VR project file would open and then display this message as it was deleted by Google and not the project file.

But also check your account, as a test go to Pano2VR's Settings and remove your Street View API key.
Restart Pano2VR and try again does it then upload?
If so this it is an issue with your account, may even be you don't have a valid payment method linked to your account.
Regards,
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
bimmler16
Posts: 2
Joined: Fri Mar 05, 2021 3:39 pm

Fri Mar 05, 2021 4:40 pm

Same Problem with my uploads since yesterday. I just want to upload a panorama to google street map,(did it the wekks before, no problem) and shortly before finishing, that message appears.
I have no api key to be removed, i shut all down, i deleted the image (which was not really uploaded), and finally the meta data try to upload, then the meta data window does not disappear and i have to close it manually.
Image
Thanks for your help
Attachments
Fehlermeldungbeim Veröffentlichen.jpg
Fehlermeldungbeim Veröffentlichen.jpg (707.63 KiB) Viewed 1806 times
User avatar
Hopki
Gnome
Posts: 11458
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Mar 05, 2021 4:46 pm

Hi,
If you are not a power user it would probably be better you get your own API key.
Please see: https://ggnome.com/doc/google-api/
Note: Make sure you understand the difference between an API ket for Street View and the one used if you want to display Google Maps in the skins Map Element.
Regards,
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
bimmler16
Posts: 2
Joined: Fri Mar 05, 2021 3:39 pm

Sun Mar 07, 2021 9:50 am

3 Days later, the panos were published in google street view, with unkown place, but published.
Thanks for your answer, i will check the API thing.
Best regards
Peter :D
User avatar
JMonaco
Posts: 20
Joined: Thu Jul 05, 2018 11:43 am
Location: California
Contact:

Mon May 17, 2021 3:23 am

Got the same error (Error transferring https://streetviewpublish.googleapis.co ... ons,places - server replied: Not Found) after deleting panos through my Google account. My APIs, their configuration in Google Maps Platform, and Pano2VR seem correct as I was able to post 5 others from the 16-node tour without any errors. Each node is associated with an existing Google place. As a test, I deleted the Map API from Advanced menu in Pano2VR, saved the project, closed it, reopened it, reinserted the API key, and same error occurred. At a loss as to how to resolve.
User avatar
Hopki
Gnome
Posts: 11458
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon May 17, 2021 5:45 pm

Hi JMonaco,
This needs further investigation but as we have not changed anything for months this is a Google problem.
The error dialogue box can be closed using the window close icon and not the Close button, again this is very odd.
However, today we just tried again and now working ok, we were seeing teh same error, so Google may have alreday fixed it.
Regards,
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
JMonaco
Posts: 20
Joined: Thu Jul 05, 2018 11:43 am
Location: California
Contact:

Mon May 17, 2021 5:48 pm

Hmmm. If I can provide information or data to help, let me know. I started getting this error after I deleted the panos in Google directly. Let's see if a day or two is necessary for Google systems to "return to normal." I just tried to upload the revised node and received the same error. The details said: {
"error": {
"code": 404,
"message": "Photo with id: CAoSLEFGMVFpcE82bThjcE5hLWpkcFI2UTV4TEtubTlsTHRGanB5c0UwMFVFdldx does not exist.",
"status": "NOT_FOUND"
}
}


Request:
{
"connections": [
{
"target": {
"id": "CAoSLEFGMVFpcE4ycmtBNTVYUnFQOGp4ZDBLVmNrMHUwNllhdTN5T3dKRjc1aGU1"
}
},
{
"target": {
"id": "CAoSLEFGMVFpcE1qZXN2OTlVUVdVRDZhc2hvMXVnMUY2M0JJVzE4Nko3ZWVmU1V1"
}
},
{
"target": {
"id": "CAoSLEFGMVFpcE5sYmN6amFZZmJLMFd1MV9EaVJRUzhfVFVlYXByMFdZZDJMOUlz"
}
},
{
"target": {
"id": "CAoSLEFGMVFpcE1RRGVzaUdscFpWTV83S3lyUFI0VzdRWWl0UUFsOXoxZ1JuWjh0"
}
},
{
"target": {
"id": "CAoSLEFGMVFpcE10X3N6QWpiNDZaNFM0RkZNS1otc3p6OTlpWFdkRWNpWFVuTXJl"
}
},
{
"target": {
"id": "CAoSLEFGMVFpcE5SelR6ZnMxQmg2RVpzR3RrVndLRFY4Y0tGUi1oaUo2dXQyNWVj"
}
},
{
"target": {
"id": "CAoSLEFGMVFpcFBLd2k4bTFEVHkybjYzREpnRTQ1WFNBdkZXUWwtOGtjcm1CZ0VO"
}
},
{
"target": {
"id": "CAoSLEFGMVFpcE5NS1ZuOXRpbUFEcDh0US14VHZyUlA1dVRmNkM5VG90Tnl0bzR3"
}
},
{
"target": {
"id": "CAoSLEFGMVFpcE94VnloZHpDaUFQZGJldUFzTU9oRzNiMEFhZHNfMHhHQllBOGhY"
}
}
],
"places": [
{
"placeId": "ChIJ8XVUtRzlmoAR-pY0TmfgmEU"
}
],
"pose": {
"altitude": 337.19,
"heading": 0,
"latLngPair": {
"latitude": 38.64058996,
"longitude": -121.0924083
}
}
}
User avatar
JMonaco
Posts: 20
Joined: Thu Jul 05, 2018 11:43 am
Location: California
Contact:

Mon May 17, 2021 6:25 pm

FIXED. I was still getting the error even after you believed Google fixed something. What I did to "clear" the error was... Deleted the Google Place I assigned to each node, saved the Project, closed Pano2VR, reopened Pano2VR, regenerated the outputs as if from scratch, and re-uploaded the revised Nodes. My rationale was, and remember that I do not understand the details well, it seemed that a PhotoID could not be found. So I figured if I could regenerate the outputs & nodes, then new PhotoIDs would be created. I think that was the fix. :D
User avatar
Hopki
Gnome
Posts: 11458
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon May 17, 2021 6:48 pm

Its Google,
What else can I say, you are in their hands.

They are the Twilight zone, they control the vertical the horizontal... :lol:

Regards,
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply