tours loads but does not respond - Wordpress

Everything concerning the Wordpress/Joomla/Drupal plugins
Post Reply
User avatar
edgar_ali
Posts: 158
Joined: Wed May 03, 2017 12:00 pm
Location: Autralia
Contact:

Wed Sep 09, 2020 1:06 pm

I created a tour and loaded using FTP protocol.

I uploaded the tour to the following page:

https://the360guide.com/pano2vr/

In this page I have loaded the tour using the following short code:

Code: Select all

[ggpkg url='https://the360guide.com/wp-content/xxx/xxx/xxx' ]
I also loaded the tour using Pano Press:

Code: Select all

[pano file="https://the360guide.com/wp-content/xxx/xxx/xxx/index.html" title="Pano2vr in Panopress" alt="Virtual reality climbing guidebook" panobox="on"]
Using the short code for Pano Press the tours loads and responds to all the commands.

Using the short code for GGPKG the tours load but does not responds to the commands (nothing happens when you click on it). Also you can see that when using pano press the font is different as when using the short code for GGPKG. Why is this happening?
Last edited by edgar_ali on Thu Sep 10, 2020 6:09 am, edited 1 time in total.
User avatar
edgar_ali
Posts: 158
Joined: Wed May 03, 2017 12:00 pm
Location: Autralia
Contact:

Wed Sep 09, 2020 1:34 pm

well I am not sure what is going on, but now is working (commands), however the fonts are still different. How can I fix this?
User avatar
Hopki
Gnome
Posts: 10748
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Sep 09, 2020 2:14 pm

Hi,
Looking at your website the CSS style sheet has not been loaded so may have something to do with why the fonts are different and any delay is displaying.

If you use the style sheet in the skin it will be included in the package.
But you can also make the package manually, please see this page: https://ggnome.com/doc/cms-wordpress/
You want the video at the bottom, but at time index 1.39 you would select all the files and create the package.
This way you can include your style sheet.

Regards
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
edgar_ali
Posts: 158
Joined: Wed May 03, 2017 12:00 pm
Location: Autralia
Contact:

Thu Sep 10, 2020 6:04 am

Hopki:

Thanks for such a quick reply...

I actually loaded the CCS style into the package, as per the instructions in the video:
https://youtu.be/iK33C9aRyHA


As you can see in the image below, I think I have included all the files required for the tour, including the CCS style, highlighted in yellow
Image

Both panopress and GGPKG plugins are using the same package, but as you can see in the page, the plugin panopress runs the tour with the proper styles/fonts, while GGPKG not.
User avatar
edgar_ali
Posts: 158
Joined: Wed May 03, 2017 12:00 pm
Location: Autralia
Contact:

Thu Sep 10, 2020 1:27 pm

In addition to my previous post:

I think I figured out what you meant by external CCS:
Image

however I do not think I have got external CCS...

I only have got fonts... I used the following method to change the fonts of the tour:
https://tonyredhead.com/pano2vr-little- ... beta-fonts
User avatar
Hopki
Gnome
Posts: 10748
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Sep 10, 2020 2:22 pm

Hi,
Have a look at this video about adding Google Fonts.
https://vimeo.com/358516909

The thing you want to look at is the class, note it's using .ggskin then the class.
This prevents "font leakage" so to speak.

Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
edgar_ali
Posts: 158
Joined: Wed May 03, 2017 12:00 pm
Location: Autralia
Contact:

Fri Sep 11, 2020 5:12 am

I updated my skin following the steps provided in:
https://vimeo.com/358516909

My skin looks like this:
Image

Image

Image

However I'm still getting the same results.

When I open the package with panopress, I get the proper fonts
Image

Image

But when using the GGPKG plugin, I still get this:
Image

I have clear the cache memory for the browser just in case but still get the same results
User avatar
Hopki
Gnome
Posts: 10748
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Sep 11, 2020 1:55 pm

This is very odd, can you send in your package to support, link below.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
edgar_ali
Posts: 158
Joined: Wed May 03, 2017 12:00 pm
Location: Autralia
Contact:

Sat Sep 12, 2020 2:45 pm

just submitted an email with the pano2vr file, the photo and the skin. Let me know if you need more information
User avatar
edgar_ali
Posts: 158
Joined: Wed May 03, 2017 12:00 pm
Location: Autralia
Contact:

Mon Sep 14, 2020 2:25 am

Guys it is working now....

I am not sure how or why this was happening...as you saw in the previous post the fonts were not loading but now everything seems to be ok...

if you visit the page https://the360guide.com/pano2vr you can double check for me
Post Reply