Wordpress Shortcode not entered

Everything concerning the Wordpress/Joomla/Drupal plugins
Post Reply
Paris
Posts: 5
Joined: Fri Oct 28, 2016 12:36 pm

Fri Oct 28, 2016 6:48 pm

Hi Support Forum,

I have a Problem with the Wordpress Plugin, I have a Wordpress 4.6.1 and installed the WP-Plugin pano2VR in Version 1.4.0.
This was all fine. I loaded successfully the the ggpgk to my Wordpress. Than I saw over the FTP connection, it will be uncompressed and everything is in a folder.
So far, so good.
Now I went to a new Post and opened the Button "Add Media" -> selected the Pano and press insert.
Regarding the instruction Video, now a shortcode with a ID would be entered.
But in my case it is still empty. I can do the process a hundred times, but nothing is visible.

So I am not able to enter any Pano2vr to my Wordpress.
Is there somebody with an idea ?

Thanks
Paris
User avatar
Hopki
Gnome
Posts: 9925
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Oct 28, 2016 9:03 pm

Hi Paris,
When you uploading the GGPKG through Wordpress you should see it upload, then say crunching.
Then when uploaded you should see the thumbnail.

When you go to your post, then select add media you should see the pano in the media section.
Selecting this should then add the string of code.

Can you provide some screen shots of all this steps to to check that they are all ok.
Even better a video but if you cant, then screen shots will be good.
Regards,
Hopki
Paris
Posts: 5
Joined: Fri Oct 28, 2016 12:36 pm

Sat Oct 29, 2016 5:40 pm

Hi Hopki,

I have done a short video with, the upload process, a short view to the FTP-Server.
The missing Shortcode in the Post insert.
And all installed Plugins.

Hope this video helps:
here the link: https://www.amazon.de/clouddrive/share/ ... _link_copy

Thanks for help.
Regards,
Paris
User avatar
Hopki
Gnome
Posts: 9925
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sat Oct 29, 2016 8:35 pm

Hi Paris,
Do you have PHP on your server?
The GGPKG requires PHP to work, please see troubleshooting on this page.
Regards,
Hopki
Paris
Posts: 5
Joined: Fri Oct 28, 2016 12:36 pm

Sun Oct 30, 2016 9:50 am

Hi Hopki,

I have done the troubleshooting. No changes. PHP is available.

Code: Select all

## Server Environment ##

Server Info:              Apache
Host:                     DBH: 127.0.0.1:3307, SRV: www
Default Timezone:         UTC
MySQL Version:            5.6.34-2

-- PHP Configuration

PHP Version:              5.6.26
PHP Post Max Size:        2000M
PHP Time Limit:           30
PHP Max Input Vars:       1000
PHP Safe Mode:            No
PHP Memory Limit:         500M
PHP Upload Max Size:      2000M
PHP Upload Max Filesize:  2000M
PHP Arg Separator:        &
PHP Allow URL File Open:  No

-- PHP Extentions

DISPLAY ERRORS:           N/A
FSOCKOPEN:                Your server supports fsockopen.
cURL:                     Your server supports cURL.
SOAP Client:              Your server has the SOAP Client enabled.
SUHOSIN:                  Your server does not have SUHOSIN installed.

-- Session Configuration

Session:                  Disabled
Session Name:             PHPSESSID
Cookie Path:              /
Save Path:                
Use Cookies:              On
Use Only Cookies:         On
---------------------------------------------------------------
the same configuration is in another Wordpress installation the same.
I have testet it in another installation on the same Server. There is everything fine.

PHP - Zip extension should be available, because the GGPKG will be extracted to a new folder.
and in the other installation it is working.
I think it is not a problem of the Server environment. At the moment I use a simple iFrame to insert it.

any other Ideas ?
Thanks
Paris
Paris
Posts: 5
Joined: Fri Oct 28, 2016 12:36 pm

Sun Oct 30, 2016 12:09 pm

In the Meantime I found additional Information to my Server, and the zip extension for PHP ist available.

Code: Select all

Configure Command 	'./configure' '--prefix=/usr/local/php5.6' '--with-config-file-path=/usr/local/php5.6/lib' '--with-gettext' '--with-gd' '--enable-gd-native-ttf' '--with-mysql=mysqlnd' '--enable-mysqlnd' '--with-mysql-sock=/tmp/mysql5.sock' '--enable-ftp' '--with-zlib' '--with-jpeg-dir=/usr/' '--with-png-dir=/usr/' '--with-zlib-dir=/usr/' '--enable-calendar' '--enable-inline-optimization' '--disable-debug' '--with-freetype-dir=/usr' '--enable-bcmath' '--with-xpm-dir=/usr/' '--with-curl' '--with-iconv' '--enable-mbstring' '--with-mcrypt' '--enable-exif' '--with-xsl' '--with-pdo-mysql=mysqlnd' '--with-openssl' '--with-mysqli=mysqlnd' '--enable-soap' '--with-imap' '--with-kerberos' '--with-imap-ssl' '--enable-sockets' '--enable-zip' '--enable-opcache' '--enable-pcntl' '--with-mhash' '--with-xmlrpc' '--with-tidy' '--enable-intl' '--with-gmp' 

Code: Select all

Registered PHP Streams	https, ftps, compress.zlib, php, file, glob, data, http, ftp, phar, zip
Paris
Posts: 5
Joined: Fri Oct 28, 2016 12:36 pm

Sun Oct 30, 2016 1:30 pm

Hi,
next what I found.
When I enter the shortcode

Code: Select all

[ggpkg id=1480]
manual to the post, it is working on the Post in the frontend.
Problem is: in this process I have to search the Post ID for the GGPKG File manual from the mysql Database.
This is possible, but not really user-friendly.

Another way to find the ID is the adressline from the browser, when the Media Preview from the Media Library is open.
Better and easier as from the mysql Database.
Screenshot.png
Screenshot.png (118.51 KiB) Viewed 2625 times
Paris
User avatar
Hopki
Gnome
Posts: 9925
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Oct 31, 2016 2:02 pm

HI Paris,
Can you send me your ggpkg as I can not reproduce the problem.
Regards,
Hopki
Post Reply