URGENT: Big problem with attachVideo with Pano2VR R3 pano

Using Pano2VR/Object2VR SWF files with your own Flash projects
Post Reply
Sascha Selent
Posts: 28
Joined: Sat Jan 24, 2009 9:36 pm

URGENT: Big problem with attachVideo with Pano2VR R3 pano

Post by Sascha Selent » Wed Apr 06, 2011 6:27 am

Hi.

We have a big problem with attaching a video via Flash CS5 AS3 to a Pano2VR R3 pano. Following the instructions in the Flash API we get the following result (blue button loads the video, red button pauses the video):
http://www.deepartmend.de/tl_files/exch ... _tour.html

We just call the API-code from the blue button:

Code: Select all

vr.attachVideo('<video url="flur_zu_kueche_2046_800_kf1_cp.flv"/>');
The attached images also show the problem - in case that the video-pano is shown properly in your Flash-Player. My Flash-Plugin for FF is 10.2.153.1.

If the video is attached via HTML / JS from Pano2VR R3 it works fine:
http://www.deepartmend.de/tl_files/exch ... _html.html

It seems that something has changed in R3 that is not documented in the API.

So please how can this be fixed?

Sascha
Attachments
Pano2VR_problem_attachVideo_01.jpg
Original pano
Pano2VR_problem_attachVideo_01.jpg (22.29 KiB) Viewed 3626 times
Pano2VR_problem_attachVideo_02.jpg
Loaded video - see the distortion at top right and bottom left
Pano2VR_problem_attachVideo_02.jpg (22.87 KiB) Viewed 3626 times
Pano2VR_problem_attachVideo_03.jpg
Weird
Pano2VR_problem_attachVideo_03.jpg (19.94 KiB) Viewed 3626 times
Pano2VR_problem_attachVideo_04.jpg
Weird
Pano2VR_problem_attachVideo_04.jpg (21.2 KiB) Viewed 3626 times
Pano2VR_problem_attachVideo_05.jpg
Weird
Pano2VR_problem_attachVideo_05.jpg (20.13 KiB) Viewed 3626 times

User avatar
thomas
Site Admin
Posts: 2483
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Re: URGENT: Big problem with attachVideo with Pano2VR R3 pan

Post by thomas » Fri Apr 08, 2011 1:40 am

Hmmm... If I use your video file it works fine in my container. You can see it at http://gardengnomesoftware.com/test/attach/ (just click on any hotspot to start video).
MfG, Thomas

Sascha Selent
Posts: 28
Joined: Sat Jan 24, 2009 9:36 pm

Re: URGENT: Big problem with attachVideo with Pano2VR R3 pan

Post by Sascha Selent » Thu Apr 28, 2011 4:24 pm

Hi Thomas.

Thanks for answering.

I saw you changed the API. You did the same as we found out to be the solution: commenting out the line

Code: Select all

//	vr.isFlash10=false; // Disable Flash 10 rendering if the container is Flash 9
This line did the problem.

So there is no fallback for Flash 9, anything you do with Pano2VR R3 needs Flash-Player 10, right?

Kind regards.

Sascha

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 2 guests