Lock out viewer controls?

Q&A about the latest versions
Post Reply
JeffN
Posts: 51
Joined: Wed Mar 04, 2009 3:40 pm

Thu Aug 12, 2010 5:08 pm

So much to do...so little time...

I've created an object move with an item spinning. I'm using the default skin and have the parameter set to auto rotate. But after outputting when I click anywhere in the movie the auto rotate stops and I can manually rotate the object.
I don't want this to happen, I don't want the viewer to be able to interact with the movie. I want it just to keep spinning, nothing else, no visible controls, no viewer control at all.

I looked at the skin editor / controls but couldn't see where / how to eliminate the viewer clicking in the movie from having any effect. The default skin just shows the loading element, no controls, and disappears, which is what I want (no visible controls).
So can any of you experts out there give me some guidance.

Much appreciated.
JeffN
User avatar
Hopki
Gnome
Posts: 10833
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Aug 12, 2010 6:25 pm

Hi
Open the skin and put a rectangle that will cover the window, and then set its alpha to 0.010.

This will stop the mouse getting to the object.
Regards
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Thu Aug 12, 2010 7:29 pm

That, or place a transparent .png file on top layer of the skin.

Regards, Smooth 8)
Image
JeffN
Posts: 51
Joined: Wed Mar 04, 2009 3:40 pm

Thu Aug 12, 2010 8:08 pm

Hopki wrote:Hi
Open the skin and put a rectangle that will cover the window, and then set its alpha to 0.010.

This will stop the mouse getting to the object.
Regards
Hopki

Hi Hopki,
I tried your suggestion. In the skin editor I drew a blank rectangle (using tool) over the grid window. The rectangle was at the bottom of the stack. Set alpha to 0.010.
Didn't work, when I render out the movie, there is no control,(as expected), but if I click inside the movie the spinning object stops.
Thoughts?
User avatar
Hopki
Gnome
Posts: 10833
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Aug 12, 2010 10:34 pm

This is very odd, I just tried it and Smooth suggestion of a transparent png and nothing worked, it seems you can not stop it.

Even tried a png at 80% and I could still rotate it with my mouse.
Over to Thomas, or unless someone else knows any different.
Regards
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
JeffN
Posts: 51
Joined: Wed Mar 04, 2009 3:40 pm

Thu Aug 12, 2010 11:09 pm

Hopki wrote: Over to Thomas,
Hopki
I don't want to over step my bounds, how would I go about getting Thomas to address this question.
Thanks
User avatar
Hopki
Gnome
Posts: 10833
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Aug 12, 2010 11:14 pm

Well normally he would see this post, but I think he is a tad busy with Pano2vr v3. Try sending him a PM
Regards
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Fri Aug 13, 2010 12:32 pm

Hopki wrote:This is very odd, I just tried it and Smooth suggestion of a transparent png and nothing worked, it seems you can not stop it.
Something has changed as both these methods use to work.
I remember others who wanted to use these in kiosk mode and only allow keyboard controls.
Hmm, maybe there was no mouse involved (memory is fading!) Nah, I'm sure this use to work....
Maybe only Pano2VR and not Object2VR?

Regards, Smooth 8)
Image
User avatar
Hopki
Gnome
Posts: 10833
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Aug 13, 2010 12:57 pm

I was also sure this would work, I did go back a few versions and got the sane thing, so perhaps just going mad. :lol:
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Fri Aug 13, 2010 1:11 pm

You'll enjoy mad, I've been living here for quite some time. :lol:

Regards, Smooth 8)
Image
juliff
Posts: 1
Joined: Sat Aug 14, 2010 9:30 pm

Sat Aug 14, 2010 9:35 pm

I have a similar situation. I have a play and pause button that toggle between auto rotate/auto rotate off. Works great. Only problem is, if it is rotating and someone clicks the movie, the movie stops and I have no way of toggling the play button back on. What I really need is a new event called "movie clicked" to be able to show my play button.
JeffN
Posts: 51
Joined: Wed Mar 04, 2009 3:40 pm

Thu Sep 02, 2010 7:24 pm

An update on this question:

Sent: Thu Sep 02, 2010 10:14 am
by thomas

I guess the best solution would be the same as in Pano2VR where you have a "disable mouse" and "disable keyboard" option. I will look into this. Maybe I can add it to the next version

Thomas said, when I asked about timing on this next version, in about 2 weeks. And he would look into the reason as to why when a text box or rectangle box is placed at the top of the skin stack and then with modifiers applied, the modifiers don't work.

So hopefully we will have a solution shortly.

jeffN
Post Reply