Auto Rotate issue / bug?

Q&A about the latest versions
Post Reply
JeffN
Posts: 51
Joined: Wed Mar 04, 2009 3:40 pm

Wed May 13, 2009 10:41 pm

Not sure if this is a bug, or what, but here's the deal...

I have flash auto play set to ping-pong, speed 0.60 Speed is good, but the auto play starts before the image is finished loading.
So to fix that issue, I have a controller skin where I have an action set to toggle auto rotate after it's finished loading, I then set the auto rotate to Off. That takes care of the rotation starting before it's fully loaded, but now when the auto rotate starts the speed is WAY to fast, (even tho before 0.60 was good). I tried several slower settings but the speed setting in the auto play window has no effect when the auto play mode is set to off, and using the action to start auto rotate.
Also, because I have to set the mode to OFF (and use the action to toggle it on), I can't choose to use the ping-pong mode, it just defaults to rotate.
Is this a bug / limitation in the software programing or is there a fix.

Thomas, if it's glitch in software, could you include a fix in the new version of Object2VR.

Regards,
JeffN
JeffN
Posts: 51
Joined: Wed Mar 04, 2009 3:40 pm

Mon Jul 13, 2009 5:04 pm

Thomas,
as no one else has responded to this question, would you check it out and please reply. I need to know if I'm just doing something wrong and how do I fix the problem. Or is this a software problem that needs attention in the next beta version.

Thanks Thomas
JeffN
User avatar
Hopki
Gnome
Posts: 10622
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Jul 13, 2009 5:34 pm

Hi Jeffn

As a thought why not do it the other way around, setup your autorotation parameters and set an "Inti" toggle autorotation and then a loaded toggle autorotation.

So Init stops it and loaded starts it when loaded.

If you don’t setup the parameters first and just start auto rotate it will use default settings, which as you have seen is not what you want.
I can not test this for the moment but I can not see why this would not work.

Hopki :)
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
andrés
Posts: 1
Joined: Fri Jul 24, 2009 7:23 am

Fri Jul 24, 2009 7:44 am

Hi , I`m trying object2vr before buy it, (I`m pano2vr user) but I have problems to get an autorotate swf.
I`m testing the swf whith the html generated whith object2vr.
I think it is because Im using a non registred version. I`m rigth or I`m doing something woung?
I`ve search on forum and try some tips but doesn`t works.

any idea ...thanks?
User avatar
Hopki
Gnome
Posts: 10622
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sat Jul 25, 2009 12:31 pm

Hi
Having had time to look at this I can confirm that if you set up your “Auto Play” parameters, say, “Pin Pong” “Speed 0.30” as an example, then add an “Init” “Stop Auto Rotate” to one of the elements in the skinl, this will do as you want.

I have a load bar so I added the above to that.

If you want the Pin Pong to start after load then just add “Loaded” “Start Auto Rotate” again in the load bar.

Load Bar Actions:
Loaded – Hide Element – Self
Init – Stop Auto Rotate
Loaded – Start Auto Rotate (option to start after load)

Cheers
Hopki :)
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply