hotspot not showing up on website

Q&A about the latest versions
Post Reply
WGHoward
Posts: 6
Joined: Wed Apr 22, 2020 12:50 pm

Wed Apr 22, 2020 6:00 pm

I have created a test hotpot in an object file and when I run it in the player locally I have no issues seeing the hotspot. however, when I export a ggpkg and pst it to WordPress and display it, there is no sign of the hotspot on the screen or in any logs. I am new to this so perhaps I missed something basic, but can't seem to find any posts suggesting a similar issue. I only added it to about 10 columns, is it possible they are being skipped when rendered on the browser screen so I don't see them?
User avatar
Hopki
Gnome
Posts: 10748
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Apr 22, 2020 7:18 pm

Hi,
What's the file format of the image?
If its SVG try PNG.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
WGHoward
Posts: 6
Joined: Wed Apr 22, 2020 12:50 pm

Wed Apr 22, 2020 7:40 pm

currently, I am just using the built-in hotspot red target point image. do I need to check off something in the interface when I export?
User avatar
Hopki
Gnome
Posts: 10748
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Apr 23, 2020 9:28 pm

Hi,
Ahhh, then use a hotspot template and image.
This is a known issue for WordPress.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
WGHoward
Posts: 6
Joined: Wed Apr 22, 2020 12:50 pm

Fri Apr 24, 2020 4:22 am

I am really having a hard time find instruction on how to do this for an object can you provide any links that spell out the process? I'm trying to mix and match tutorials from p2vr and o2vr with no luck.

this video is no longer available.
http://support.ggno.me/howto_videos/Obj ... otspot.mp4
User avatar
Hopki
Gnome
Posts: 10748
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Apr 24, 2020 5:18 pm

Hi,
Please see the attached project.
In the skin, there is a Hotspot Template and an image which is a child element of it.
The hotspot template needs actions but you can add them.

The Hotspot Editor lets you add the hotspots, then define the template you want to use for that hotspot.
In this case, there is only one hotspot "Hotspot Template".
But in the skin I could have another one, with a different image.

Regards,
Attachments
Reindeer JPG.zip
(290.75 KiB) Downloaded 40 times
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
vreality
Posts: 1
Joined: Thu Mar 12, 2020 6:16 pm

Tue Jun 09, 2020 5:33 pm

Hello, i followed this for my project, it works until the step to add link to hotspots, the hotspot template are not clickable ( the link set on hotspot template does not react to mouse click)

deas this need to add hotspot template and set actions for every hotspot :shock: thou it's same appearance ?

here is the project i'm wordking on

http://3dma.ma/?page_id=267

any help please ?
Post Reply