Vertical scrolling over an object

Q&A about the latest versions
Post Reply
PPotthoff
Posts: 14
Joined: Thu Feb 23, 2017 4:26 pm
Location: Dortmund, Germany

Mon Feb 27, 2017 9:29 am

Hello,

I am using Object2VR.

I am embedding my object on a bootstrap based website.
The website got a lot of more content, so I do have to scroll on it.

But if I am emebedding my obj on the website, there is no chance to scroll down over it. So I dont have the chance to see the content after my object.
I am not sure but i think it is because of the z-index and overflow: hidden.

I already tried to remove those styles with Firebug, but i still got the problem.
Any ideas?

Thank you so far.

Cheerio,
Patrick
User avatar
Hopki
Gnome
Posts: 10865
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Feb 27, 2017 9:39 pm

Hi Patrick,
The mouse will have ficus on the page and will scroll down until its gets to the object, the object will then get focus and the scroll would then become zoom if activated in the project file.
You need to have borders so the mouse pointer stays in the web page when you scroll.
May be think about making the display window smaller in the page so it easier to scroll past the object.
Regards,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
PPotthoff
Posts: 14
Joined: Thu Feb 23, 2017 4:26 pm
Location: Dortmund, Germany

Tue Feb 28, 2017 7:32 am

Hey Martin,

isnt there any chance to disable the zooming on my object? So there would be no problem with scrolling over the object.

Cheerio,

Patrick
User avatar
Hopki
Gnome
Posts: 10865
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Tue Feb 28, 2017 6:30 pm

Not really as you will need the mouse to still have focus to click and drag the object around.
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
PPotthoff
Posts: 14
Joined: Thu Feb 23, 2017 4:26 pm
Location: Dortmund, Germany

Thu Mar 02, 2017 9:34 am

Hey,

I resolved the problem.

I just removed the following lines in the object2vr_player.js :

ab ? (
q.addEventListener("mousewheel", Ea, !1),
x.addEventListener("mousewheel", Ea, !1)
) : (
a.addEventListener("mousewheel", Ea, !1),
a.addEventListener("DOMMouseScroll", Ea, !1)
),

Now I am able to scroll over my object without zooming into it.

Is there any possibility for the next release that you add some parameters to disable this Mousescroll event easily with true or false?
I would appreciate this!

Thank you so far.

Cheerio,
Patrick
User avatar
Hopki
Gnome
Posts: 10865
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Mar 02, 2017 6:09 pm

Hi Patrick,
Did you by chance try to disable the mouse wheel under the advanced settings of the HTML5 output.
If not try this to see if this works for you.
Regards,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply