Issue with PNGs and multiresolution

Q&A about the latest versions
Post Reply
jgrantps
Posts: 7
Joined: Thu May 31, 2018 2:31 am

Issue with PNGs and multiresolution

Post by jgrantps » Thu May 31, 2018 2:58 pm

I have run into a weird problem with my current object2vr project. I want to use an HTML5 with multiresolution for mobile friendly/optimized load times, and I want to have the images transparent so that I can control the background color through the HTML.

I used the tiling setting of "tiles/c%c_l%r_%y_%x.jpg", and I changed the .jpg to .png in the HTML settings to get the right output. It seams to be producing PNGs with the correct alphas.

When I publish it, things get weird. You can take a look here: http://avatarstudios.ca/foundations/ The images smear across the screen when rotated, and the smearing vanishes when you adjust the browser window.

I don't have this problem when I use the .jpg image type with multiresolution, but that file type produces a black background so it won't really work for this project (on a side note, is there any way to adjust the color for the background of a multiresolution HTML5 output when outputting using jpgs?)

Any advice on how to correct this would be appreciated!

GIOLETS
Posts: 22
Joined: Thu Mar 27, 2008 12:48 pm

Re: Issue with PNGs and multiresolution

Post by GIOLETS » Mon Aug 06, 2018 7:00 pm

I found the same here, with PNG seems that that each image viewed in the browser remain visible in backgrpound, the result is funny:

20180806185848.jpg
20180806185848.jpg (270.17 KiB) Viewed 396 times
I wonder if there is a chance to have transparent png without this issue...

User avatar
Hopki
Gnome
Posts: 8562
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Issue with PNGs and multiresolution

Post by Hopki » Tue Aug 07, 2018 4:53 pm

Hi,
It only happens in multi resolution, try this with a single resolution does it work?
Regards,
Hopki

GIOLETS
Posts: 22
Joined: Thu Mar 27, 2008 12:48 pm

Re: Issue with PNGs and multiresolution

Post by GIOLETS » Sat Aug 18, 2018 4:50 pm

Yes of course it works, but I need multiresolution for my projects, so when this problem will be fixed?

And in addition I have noticed, please confirm that is my mistake, that with multiresolution I have always a black background also if I choosed different one in "display settings".

So if you not deny me with multiresolution the only option is to have a black background, doesn't matter if you have choosed another one color, if you have PNG file, etc.. correct?

jgrantps
Posts: 7
Joined: Thu May 31, 2018 2:31 am

Re: Issue with PNGs and multiresolution

Post by jgrantps » Fri Aug 24, 2018 7:08 pm

my example is now offline, but to answer hopki's question - it happens with multresolution, not necessarily single resolution. The software glitches for some reason when you either turn the display background off or set the display to 0 alpha - the generated outputs will still sometimes have the color set in the display background at 255 alpha even though the display background is deactivated. After fiddling around with it I've been able to generate outputs that have the background run off the html color.


Multiresolution is a write-off though - it still just stacks the images on top of each other, producing the mess you've been seeing.

User avatar
Hopki
Gnome
Posts: 8562
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Issue with PNGs and multiresolution

Post by Hopki » Mon Aug 27, 2018 4:02 pm

Hi Guys,
If your embedding the object using an iframe but don't want to see the background then you need to add this to the Objects HTML page:

Code: Select all

<style type="text/css">
    			html,
    			body {
      			background-color: transparent;
    		}
  		</style>
Add to the end of the head section of the HTML page.
Working on getting Pano2VR 6 out of beta first then we will be looking at Object2VR.
Regards,
Hopki

jgrantps
Posts: 7
Joined: Thu May 31, 2018 2:31 am

Re: Issue with PNGs and multiresolution

Post by jgrantps » Wed Aug 29, 2018 7:51 pm

Thanks Hopki - I've tried that out - you can check the code with my published test here:

http://avatarstudios.ca/test2/

This is a multi-resolution tour published with the generated files as .pngs. Not sure if your code addition was put in properly (I know nothing about code!), so my ignorance may be to blame, but nonetheless it is still producing the same result as before.

My ultimate goal is to have the tour present with a fully transparent background so that the website it's on provides the background... a there are a couple of sites I work with that have grids as their background, and it's impossible to align the grid properly using the object2VR editor and a jpg-based output. I'm able to achieve the transparency that I'm wanting (with your code?), but it is the smearing of the image that is the main problem now. Do you know if there could be a fix for this?

User avatar
Hopki
Gnome
Posts: 8562
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Issue with PNGs and multiresolution

Post by Hopki » Mon Sep 10, 2018 8:54 pm

Did you try single resolution?
Regards,
Hopki

jgrantps
Posts: 7
Joined: Thu May 31, 2018 2:31 am

Re: Issue with PNGs and multiresolution

Post by jgrantps » Fri Oct 05, 2018 4:12 pm

Oops - sorry about missing this.

Yes, I've tried single resolution and it works the way you would expect. It is only an issue with multi-resolution...

User avatar
Hopki
Gnome
Posts: 8562
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Issue with PNGs and multiresolution

Post by Hopki » Fri Oct 05, 2018 8:18 pm

Hi,
Yep, thanks for confirming.
Regards,
Hopki

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 6 guests