"Hide Element" not working in HTML5

Special forum to share and discuss skins for Pano2VR and Object2VR
Post Reply
jmcilvaine
Posts: 48
Joined: Thu Oct 11, 2012 11:59 am

"Hide Element" not working in HTML5

Post by jmcilvaine » Mon Dec 23, 2013 2:36 pm

Hi all and Happy Holidays!

I just upgraded to Pro (love it!) and am having a couple issues with HTML5 output.

http://tours.inmotionrems.com/responsive-tabs.php

The tour starts with the plan visible. I have an action to hide the plan when the markers are clicked, which works fine in Flash but not in HTML5. This looks to be an issue with the Node Marker, I also have a Hide Element action on the floor plan thumb at the bottom left which does toggle the plan for me in HTML5. Just wondering if I am doing something wrong or if this is an issue. This is ultimately not a big deal 95% of "desktop" visitors will have Flash installed and I plan to have a separate "mobile" version of the tour. More just wondering why Hide Element is not working on HTML5.

Another small issue is the HTML seems to handle the font size different than Flash.

Thanks!

Joe

User avatar
Hopki
Gnome
Posts: 9651
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: "Hide Element" not working in HTML5

Post by Hopki » Mon Dec 30, 2013 2:48 pm

Hi Joe,
I would need to see your skin before I can say for sure but I take it you have a mouse click hide map action in the map markers are clicked?
Regards,
Hopki

jmcilvaine
Posts: 48
Joined: Thu Oct 11, 2012 11:59 am

Re: "Hide Element" not working in HTML5

Post by jmcilvaine » Mon Dec 30, 2013 9:55 pm

Hi Hopki!

I've moved on to to a different skin for flash. I'm going to do a separate HTML skin and a mobile skin. I've had the opportunity to play around with Pro and I can only say I wish I upgraded much sooner! I can see where I will be able to produce a tour FASTER than with the cloud based service and the quality with Pano2VR is much better and I have much more control over the end product. That said, I am hoping you can help me out with the Flash skin I am working on:

http://tours.inmotionrems.com/test_rema ... remap.html

I modified your Pro Thumbnail skin and added my elements and am vry close to what I want for the Flash skin. If you hover over the first thumbnail you will see a "mini preview pano". My question: Is there a way that I can use node markers to get that to work. What I would like is to be able to be able to hover over the thumbnails, and the corresponding Pano and Title appear with my having to create separate elements for each mini pano. I have attached the skin.

Also here is the entire project, with project, image and output files. It also includes a droplet to make the mini panos (about 72MB):

http://tours.inmotionrems.com/dropbox/test_remap.zip

I'm just looking for the most streamlined way possible to create the tour. The example here is 1/2 of a 16 node tour I did recently. I'm just hoping there is a way around having to manually add all mini panos to the skin. You'll better understand what I am talking about when you see the project.

Thanks!

Joe
Attachments
test_skin1.ggsk
(1.4 MiB) Downloaded 90 times

jmcilvaine
Posts: 48
Joined: Thu Oct 11, 2012 11:59 am

Re: "Hide Element" not working in HTML5

Post by jmcilvaine » Thu Jan 02, 2014 4:21 pm

Figured out the "mini preview" using node markers. It was another situation of my having to wrap my head around how node markers work. Finally got a decent finished product:

http://tours.inmotionrems.com/unbranded/F1261953.php

Next is the mobile version...:), which will be a stripped down version of this skin. Now that I somewhat know what I am doing (after 2 years of fiddling around....hehehe) it should go a bit easier. I'll post a bit about the skin in the tour gallery thread.

Thanks!

Joe

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests