Images for Map in Skin appear in wrong place!! How to fix?

Special forum to share and discuss skins for Pano2VR and Object2VR
Post Reply
AncientCityPhoto
Posts: 50
Joined: Wed Sep 21, 2011 4:25 pm

Wed Sep 21, 2011 5:08 pm

Ok I am testing out a skin I am making. I will eventually swap out graphics for a custom set. However On the map I want to set two points and make the white circle and compass appear on the hotspot as you click through. Like on the sample tour.

However, no matter what I program in, it seems as if the compass and white circle appear somewhere else on the screen. I have added the init and on click to appear on $self from the black circles. No matter what though, the white circle keeps appearing somewhere else on the screen.

I just can't figure out what I am doing wrong. Everything else seem to work fine so far. I am trying to build one step at a time to make sure I have a good understanding. I am just stumped at this point. Can any body please help identify my issue? I made the black circle actions just like the sample project for the most part.

Here is a link to the testing platform to see what is going on with the map circles.

http://ancientcityphoto.com/virtualtour ... _yard.html

Thank you so much for any help. I really appreciate it.
User avatar
Hopki
Gnome
Posts: 10744
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Sep 22, 2011 10:39 am

I also received this as a support e-mail.
The problem was the white circle was not in the correct level in the file tree, it needed to be a child of the map element, the same as the other map hotspots.
This is a very easy mistake to make which causes the $self action not to work as expected.
Regards
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply