Using a timer to delay the start of an intro YouTube video

Special forum to share and discuss skins for Pano2VR and Object2VR
Post Reply
User avatar
Enviropix
Posts: 51
Joined: Thu Jul 30, 2009 8:19 pm
Location: Scottsdale, Arizona
Contact:

Tue Apr 14, 2020 4:43 pm

Hello,

I'm sure this is an easy process, however I can't seem to figure it out. I have a YouTube video that launches as an intro video and disappears after it plays with a logic block. But what I want to happen is to let the fly-in animation play first, then have the video show/play after the fly-in stops.

Any thoughts from the collective?

Best,

Jeff
User avatar
Hopki
Gnome
Posts: 10833
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Apr 15, 2020 8:35 pm

Hi Jeff,
Just add a timer to the skin with the following set up.
Type: start
Timeout: 3 seconds
Repeat: One Time
Then give it the Action Deactivate, Playe Media, loop 1, the video element.

Note the video can not have any sound or the video element is set to mute, browsers will not allow autostart of media with sound.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
Enviropix
Posts: 51
Joined: Thu Jul 30, 2009 8:19 pm
Location: Scottsdale, Arizona
Contact:

Wed Apr 15, 2020 9:07 pm

Hi Hopki,

As always, thanks for your help! And thanks again for another great webinar today! You really are a Jedi Master with your knowledge and teaching skills in the "skin" world!

Best,

Jeff
User avatar
Hopki
Gnome
Posts: 10833
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Apr 15, 2020 9:12 pm

Thank you Jeff,
Just hope they come across OK.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
Enviropix
Posts: 51
Joined: Thu Jul 30, 2009 8:19 pm
Location: Scottsdale, Arizona
Contact:

Mon Apr 27, 2020 7:47 pm

Hello Hopki,

A couple of weeks ago you assisted me with an intro video delay, and today is my first opportunity to implement your teachings. Unfortunately the problem persists and perhaps you could take a peek at the skin and tell me why it's not delaying or perhaps not "hiding" it from being "displayed" as the "fly-in" intro plays first. This is especially pertinent for those who view this on their mobile devices.

Here's the skin: YouTube_intro.ggsk

And here's the published output: https://360niche.com/tours/mp/joe-roth/vtour.html

As always,

Thank you for your help.

Jeff
Attachments
YouTube_intro.ggsk
(1.29 KiB) Downloaded 27 times
User avatar
Hopki
Gnome
Posts: 10833
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Apr 27, 2020 8:46 pm

Hi Jeff,
You almost got it.
You just needed to deselect visible of the time.
So it's hidden until the timer stops then it shows.
Unfortunately, due to browser restrictions, it will not autoplay, but at least it shows after the fly-in.
See project attached.
Regards,
Attachments
jeff.zip
(13.58 KiB) Downloaded 35 times
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
Enviropix
Posts: 51
Joined: Thu Jul 30, 2009 8:19 pm
Location: Scottsdale, Arizona
Contact:

Tue Apr 28, 2020 4:37 pm

Thanks again Hopki!

Btw, I'm having so much fun learning from the webinars and being so creative during these strange times...

Cheers!

Jeff
User avatar
Hopki
Gnome
Posts: 10833
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Apr 30, 2020 10:53 pm

Hi Jeff,
Thank you for your kind words.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply