Page 1 of 1

popup video on startup

Posted: Wed May 29, 2019 1:31 pm
by stalwart
I've done a gallery VT and filmed an intro video with a presenter. We'd like this to appear on tour start up as an intro splash with opaque screen tint which the user closes the video to start the tour. How can I amend the Video Popup Simplex (File) in the Components Toolbox to launch video on startup?

TIA.

Stu

Re: popup video on startup

Posted: Thu May 30, 2019 9:46 pm
by Hopki
Hi Stu,
Add a video element to your skin 100% x 100% set to visible and point the URL to the video in the projects folder.
The trick is to add this to the CSS Inner Element:

Code: Select all

object-fit: cover; overflow: hidden;
This will fill the video window.
You can add a button graphic to start the video, I'm using a text box.
Regards,
Hopki

Re: popup video on startup

Posted: Sun Jun 02, 2019 8:29 pm
by stalwart
Hi Martin,

Works - to a point - the video fills the screen width-wise, but crops top/bottom. How do I make the video (which was shot in portrait) fit top/bottom....?

Stu

Re: popup video on startup

Posted: Mon Jun 03, 2019 1:27 pm
by Hopki
Hummmm,
The CSS just fills the window using the shortest edge and cropping the longest, the only way that you can have a fullscreen video display with different screen aspect ratio.
If your happy to see borders just remove the CSS, it should fill using the longest edge and show boarders.
Of course, you can use a background rectangle to cover the panorama.
Regards,
Hopki

Re: popup video on startup

Posted: Mon Jun 03, 2019 11:21 pm
by stalwart
Works on desktop but doesn't seem to want to work on iOS (iPhone 8 Plus): https://www.360imagery.co.uk/draft/carb ... gallery_3/

Re: popup video on startup

Posted: Tue Jun 04, 2019 2:42 pm
by Hopki
Hummmm, how have you added the video?
Also not working in iPhone7.
Try the attached project.
It uses a media end to hide everything so you can pause and stop it and it will still show, but if you scrub to the end and let it finish it hides elements.
Regards,
Hopki

Re: popup video on startup

Posted: Tue Jun 04, 2019 10:04 pm
by stalwart
Cheers bud - will give that a try Thursday when back in the office. Currently in Eype, Dorset for 2 jobs tomorrow morning....

Re: popup video on startup

Posted: Thu Jun 06, 2019 3:52 pm
by stalwart
Hopki wrote:
Tue Jun 04, 2019 2:42 pm
Hummmm, how have you added the video?
Also not working in iPhone7.
Try the attached project.
It uses a media end to hide everything so you can pause and stop it and it will still show, but if you scrub to the end and let it finish it hides elements.
Regards,
Hopki
The video is still not playing on iOS with this new project. Screen tint & media buttons appear, but no video....
https://www.360imagery.co.uk/draft/carb ... gallery_3/

Stu