popup video on startup

Special forum to share and discuss skins for Pano2VR and Object2VR
Post Reply
User avatar
stalwart
Posts: 640
Joined: Thu Oct 02, 2008 11:52 am

popup video on startup

Post by stalwart » Wed May 29, 2019 1:31 pm

I've done a gallery VT and filmed an intro video with a presenter. We'd like this to appear on tour start up as an intro splash with opaque screen tint which the user closes the video to start the tour. How can I amend the Video Popup Simplex (File) in the Components Toolbox to launch video on startup?

TIA.

Stu

User avatar
Hopki
Gnome
Posts: 9642
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: popup video on startup

Post by Hopki » Thu May 30, 2019 9:46 pm

Hi Stu,
Add a video element to your skin 100% x 100% set to visible and point the URL to the video in the projects folder.
The trick is to add this to the CSS Inner Element:

Code: Select all

object-fit: cover; overflow: hidden;
This will fill the video window.
You can add a button graphic to start the video, I'm using a text box.
Regards,
Hopki
Attachments
intro_video.zip
(3.14 MiB) Downloaded 43 times

User avatar
stalwart
Posts: 640
Joined: Thu Oct 02, 2008 11:52 am

Re: popup video on startup

Post by stalwart » Sun Jun 02, 2019 8:29 pm

Hi Martin,

Works - to a point - the video fills the screen width-wise, but crops top/bottom. How do I make the video (which was shot in portrait) fit top/bottom....?

Stu

User avatar
Hopki
Gnome
Posts: 9642
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: popup video on startup

Post by Hopki » Mon Jun 03, 2019 1:27 pm

Hummmm,
The CSS just fills the window using the shortest edge and cropping the longest, the only way that you can have a fullscreen video display with different screen aspect ratio.
If your happy to see borders just remove the CSS, it should fill using the longest edge and show boarders.
Of course, you can use a background rectangle to cover the panorama.
Regards,
Hopki

User avatar
stalwart
Posts: 640
Joined: Thu Oct 02, 2008 11:52 am

Re: popup video on startup

Post by stalwart » Mon Jun 03, 2019 11:21 pm

Works on desktop but doesn't seem to want to work on iOS (iPhone 8 Plus): https://www.360imagery.co.uk/draft/carb ... gallery_3/

User avatar
Hopki
Gnome
Posts: 9642
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: popup video on startup

Post by Hopki » Tue Jun 04, 2019 2:42 pm

Hummmm, how have you added the video?
Also not working in iPhone7.
Try the attached project.
It uses a media end to hide everything so you can pause and stop it and it will still show, but if you scrub to the end and let it finish it hides elements.
Regards,
Hopki
Attachments
stu.zip
(2.74 MiB) Downloaded 33 times

User avatar
stalwart
Posts: 640
Joined: Thu Oct 02, 2008 11:52 am

Re: popup video on startup

Post by stalwart » Tue Jun 04, 2019 10:04 pm

Cheers bud - will give that a try Thursday when back in the office. Currently in Eype, Dorset for 2 jobs tomorrow morning....

User avatar
stalwart
Posts: 640
Joined: Thu Oct 02, 2008 11:52 am

Re: popup video on startup

Post by stalwart » Thu Jun 06, 2019 3:52 pm

Hopki wrote:
Tue Jun 04, 2019 2:42 pm
Hummmm, how have you added the video?
Also not working in iPhone7.
Try the attached project.
It uses a media end to hide everything so you can pause and stop it and it will still show, but if you scrub to the end and let it finish it hides elements.
Regards,
Hopki
The video is still not playing on iOS with this new project. Screen tint & media buttons appear, but no video....
https://www.360imagery.co.uk/draft/carb ... gallery_3/

Stu

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests