Action Problem / moving object

Special forum to share and discuss skins for Pano2VR and Object2VR
Post Reply
Patrick
Posts: 83
Joined: Fri Mar 16, 2012 11:46 am
Location: Germany
Contact:

Thu Nov 15, 2018 9:50 am

Good morning all,
I have the following problem and can not find the solution.
I wrapped a skin with a Maker (arrow) always shows the active panorama in the menu on the page. So I click on Panorama 1 and my arrow moves to the menu item Panorama 1. If you click on Panoarama 2 in the menu, the arrow moves to menu item 2. If a panorama is called up via a hotspot, the arrow also moves to the desired menu item. Thus, the viewer always has an overview of where he is.

I used this skin for several objects for a client and just modifiez the links, texts and menu items in the skin. Unfortunately, this works no longer with the Maker (arrow) The arrow moves to the menu item when I call the panorama on the menu bar, but not when I call the panorama via a hotspot.

Here is a link to the working skin and a picture of the action in the skin.

http://kunden.patrickjelen.de/web/index.html
Attachments
Bildschirmfoto 2018-11-15 um 09.35.58.png
Bildschirmfoto 2018-11-15 um 09.35.58.png (50.34 KiB) Viewed 962 times
User avatar
Hopki
Gnome
Posts: 11134
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Nov 19, 2018 9:36 pm

Hi,
I take it you found the problem as when testing your link I get the arrow moving when using either the hotspot or menu.
Regards,
Hopki
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Patrick
Posts: 83
Joined: Fri Mar 16, 2012 11:46 am
Location: Germany
Contact:

Wed Nov 21, 2018 11:54 am

Hi Hopki,
No, unfortunately not. If I use this skin (link) for another job this will not work. The arrow only moves to the desired object when I click directly on the item in the menu. But not about the hotspot. Then the arrow (marker) simply stops.

Should I send you the skin?

Thanks
Patrick
User avatar
Hopki
Gnome
Posts: 11134
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Nov 23, 2018 11:47 pm

Hi Patrick,
Yes please.
Regards,
Hopki
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
Hopki
Gnome
Posts: 11134
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Nov 30, 2018 10:47 am

Hi Patrick,
Looking at your skin and the menu I would have used node markers.
The reason why is a node marker can detect that the node is active.
So it does not matter how you get to a node it can still react.

In your skin rather than remake it you can just add node markers for each menu item.
Example:
Add node marker and position X:0 Y:0
Give the ID: Link1 Marker
Under the node markers properties and the Node Marker tab add Node: DJH Essen
Give it the action: Activate, Trigger Click, Link_1

Make for for each menu item making sure it Node is linked to the correct node.
As that node becomes active it creates a trigger click that then moves the pointer to the correct position.

Moving forward you would use node markers with the text box as the child element.
Regards,
Hopki
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Patrick
Posts: 83
Joined: Fri Mar 16, 2012 11:46 am
Location: Germany
Contact:

Tue Dec 04, 2018 2:24 pm

Thank you Hopki!
I have found the main error. It was the Hotspotproxy ID that was wrongly registered.

Now it works perfect again..........
Post Reply