Changing alpha on Map element (floorplan) issue (bug)

Special forum to share and discuss skins for Pano2VR and Object2VR
Post Reply
mbb
Posts: 210
Joined: Mon Oct 19, 2009 11:42 pm

Changing alpha on Map element (floorplan) issue (bug)

Post by mbb » Wed Oct 17, 2018 8:57 am

P2VR v6b4, Win10-64

Issue- Floorplan has transparent background as expected (and set), however an action to change or toggle the alpha (in order to have it fade in/out) does not preserve the transparency of the floorplan, *unless* the map element is given a non zero default alpha value (eg: .01).

mbb
Posts: 210
Joined: Mon Oct 19, 2009 11:42 pm

Re: Changing alpha on Map element (floorplan) issue (bug)

Post by mbb » Wed Oct 17, 2018 6:29 pm

Also on the topic of floorplans-

The floorplan images themselves should be "permeable", with only the map spots clickable. This is especially important if one has irregular shaped floorplans with a transparent background, in order to allow mouse clicking for panning if one happens to click within that transparent area without realizing it.

How is this an issue? My floorplans are often isometric, so they do not fit nicely or look nicely in a "box". So I make the area outside the floorplan itself transparent. This gives a nice clean presentation. However, users will often attempt to click to pan on the larger area that is part of the transparency of the floorplan, making the panning not seem to work for them.

**UPDATE

I have a "fix" for this "clickable" issue.. If you set the Map element itself to "Permeable", the built-in Map Markers won't accept clicks, but if you assign your own node marker for the Floorplan, the markers will accepts clicks when the Map element itself is "permeable".

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests