Google Maps API - "Oops! Something went wrong."

Special forum to share and discuss skins for Pano2VR and Object2VR
Post Reply
User avatar
Tony
Posts: 1014
Joined: Mon Feb 15, 2010 6:54 am
Location: Adelaide, South Australia
Contact:

Fri Jan 26, 2018 7:28 am

Hi,

I'm struggling to get a Google Map to work inside a Pano2VR tour I'm working on. I've generated a Google Map API key and added it to the map in the skin. When I generated the project the correct map shows for a second and then I get the "Oops" error message and in the Javascript console it tells me ApiNotActivatedMapError. Anyone have any hints on how to get this working?

Here's a link to a quick test I did https://rebrand.ly/maptest

Update: Okay for some reason it's started working now. I went into the https://console.developers.google.com/apis/dashboard and played around with some settings but I have no idea what I was doing.

Is there a time delay before the API is registered and working? I tried sharing the map component to another project but got the Oops error. Do you need a different API for each project?

Tony

image-81.png
image-81.png (524.81 KiB) Viewed 1269 times
image-82.png
image-82.png (411.36 KiB) Viewed 1269 times
image-83.png
image-83.png (1.01 MiB) Viewed 1269 times
Tony Redhead | Panoramic Photographer | mobile: +61438501002 | website: http://tonyredhead.com - http://redsquare.com | roundme: http://round.me/@tonyredhead | instagram: https://www.instagram.com/tonyredhead/
RZ500
Posts: 7
Joined: Thu Nov 12, 2020 10:32 am
Location: Mexico

Sat Nov 28, 2020 2:44 am

I had the same problem, but my solution was in the skin I use the web API key and that happens, so for testing I use the developer key and worked fine, before I upload to the web I change the key for the web one and once up there it worked fine
User avatar
Hopki
Gnome
Posts: 11017
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sat Nov 28, 2020 8:49 pm

Hi Tony,
The map seems to be ok now.
Regards,
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply