Timer issue with ht_image

Special forum to share and discuss skins for Pano2VR and Object2VR
Post Reply
Vitaly
Posts: 34
Joined: Thu Oct 06, 2011 9:12 pm
Location: Ukraine
Contact:

Sat Feb 13, 2016 4:55 pm

Pano2VR 5 beta5 64bit
Strange issue with a timer:
I need activate timer after clicking on popup image (ht_image)
Timer is added to skin. Timeout set to 0, Type "init", repeat "One time"

So I add action for ht_image:
Source: Mouse Click
Action: Set Value
Parameter: 3
Target: Timer 1

Also I placed some SVG as a test button and add the same actions for activating timer

Clicking on ht_image all works except activating timer. Clicking on test SVG button activates timer as expected.
I tried to change order with actions in ht_image, placing timer to the top but it can't help.
Why HT_IMAGE click can't activate the timer?
User avatar
Hopki
Gnome
Posts: 10622
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sat Feb 13, 2016 7:54 pm

Hi,
Its an issue with the Set Value action when used in a hotspot template.
You can use a node marker or container and then use hotspot proxy ID.

Please see attached project, key elements that make this work:
Hotspot ID = pop
Node Marker with ID trigger has the hotspot proxy ID = pop
The Timer opens and closes the popup as well as setting blank text to unload the image.
The Hotspot Template has the Set Value action to show the requires popup Image.
Regards,
Hopki
Attachments
ht_image.zip
(619.22 KiB) Downloaded 95 times
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Vitaly
Posts: 34
Joined: Thu Oct 06, 2011 9:12 pm
Location: Ukraine
Contact:

Sun Feb 14, 2016 10:53 am

Thank you, Hopki!
Your trick is working. By the way, I saw placeholder $r in ht_image actions.
This placeholder is absent in List of Placeholders and System Placeholders
By testing I found $r = images folder name.
Post Reply